Hallo alle zusammen,

wie am 13.03. geschrieben, hat mir neulich ein Windows-Update ziemlich viel zerstört, darunter eben auch meinen Grub, den ich auf meiner NVMe-SSD installiert hatte. So kam ich erst einmal nicht mehr an mein Manjaro heran, dass ehrlich gesagt, ziemlich bescheiden lief, es startete zwar grob, aber herunterfahren war nicht möglich und diverse Dinge liefen einfach auch nicht so rund, wie ich mir das vorgestellt habe. Da ich die Manjaro-Umgebung sowieso nur spartanisch eingerichtet habe, habe ich mir überlegt, vielleicht eine Distribution zu nehmen, die etwas runder läuft. Erst wollte ich ein Standard Ubuntu 18.04 nutzen, normalerweise ist Ubuntu ja das Linux was eigentlich fast überall läuft. Gesagt, getan, Ubuntu heruntergeladen, mit dem Win32DiskImager einen Boot-USB-Stick erstellt und gestartet. Nach dem Boot-Bildschirm hat sich mein Notebook bloß  nach ca. 5-10s rebootet. Auch mit verschiedenen Parametern, wie nomodeset bzw. acpi=off ließ sich dieses Problem nicht beheben. Also erst mal eine Sackgasse.

Heute habe ich mir dann mal Linux-Lite heruntergeladen. Ich hatte das schon mal vor ein paar Monaten mal getestet – es hat mich vor allem durch seine XFCE-Oberfläche (ja, ich weiß, das ist total Oldschool, aber ich mag XFCE) und seinem trotzdem recht hübschen, frischen Look überzeugt. Damals hatte ich mir eine Linux-Zeitschrift geholt und lustigerweise war Linux Lite das Linux, was am einfachsten in den Live-Modus zu booten war.

Also habe ich ihm noch mal eine Chance gegeben. Also erneut: Image runterladen, einen Boot-Stick erstellen und dann starten. Der erste Start ohne Anpassung der Bootparameter ging natürlich mal wieder in die Hose. Der zweite Start mit zusätzlichen Boot-Parametern: noacpi und nomodeset hat dann Linux Lite dazu bewegt, das Live-System zu booten – cool. Dann installiert – meine Platte hatte ja noch eine Ext3 bzw. Ext4-Partition vom Manjaro, die Installation hat nur wenige Minuten gedauert und dann konnte ich das System auch schon starten. Wieder habe ich als boot-Parameter:

noacpi und nomodeset

eingestellt, zwar bootete Linux Lite dann problemlos aber das System war unnutzbar langsam. Die CPU-Auslastung von Xorg lag bei über 100%, so ließ sich überhaupt nicht arbeiten. Also habe ich mich kurz noch einmal im Netz schlau gemacht und einfach mal ein bisschen mit den Boot-Parametern gespielt.

Irgendwo stieß ich dann auf folgenden Hinweis:

nouveau.modeset=0

als Bootparameter vom Linux-Kern eingeben schaltet den freien NVidia-Treiber ab und bootet mit dem Intel-Treiber. Und siehe da, ab dann lief auch XFCE pfeilschnell und auch Herunterfahren und alles andere läuft ab sofort.

Cool.

Klar, Linux-Lite ist an manchen Stellen noch nicht so perfekt – irgendwie ist in den Menüs nur die Hälfte auf Deutsch übersetzt – das andere ist noch auf Englisch und es ist etwas Handarbeit nötig, um verschiedene Apps zum Laufen zu bekommen, aber sonst funktioniert erstaunlich viel out of the box. WLAN hat sofort funktioniert, ebenso wie Bluetooth, Audio, Touchpad uvm.

Ich bin echt begeistert und froh, dass endlich mal ein Linux wirklich ordentlich auf meinem Notebook läuft.

Daher werde ich wohl öfter mal von Linux-Lite-Dingen berichten.

Schreibe einen Kommentar

Artikel, die Dir auch gefallen könnten

Homepage für Seifenblase Dresden

Hallo zusammen, lange ist es nun her, seitdem ich das letzte Mal was geschrieben habe, irgendwie ist auch immer laufend irgendetwas, so dass ich gar

mehr...

Free Your IT endlich online

Hallo da draußen, endlich sind meine ersten beiden Tutorial-Videos inkl. eines kleinen Vorstellungs-Videos online. Da ich grundsätzlich weg möchte von den zensurbehafteten Plattformen habe ich

mehr...

HTTPS-Abrufe mit Java

Hallo da draußen, gerade musste ich wieder einige Zeit lang schwitzen, weil bei meinem Cutworks-Projekt nach einer (vergessenen) SSL-Zertifikatserneuerung plötzlich eine essentielle Funktion ausgefallen und

mehr...